New vs returning visitor data is inaccurate for some historical reports
Incident Report for Parse.ly
Resolved
This issue is now resolved. Most historical rebuilds should be completed. Please contact support if you notice any incorrect data and we’ll investigate and prioritize a rebuild of the affected period.
Posted Sep 28, 2021 - 21:51 UTC
Monitoring
On Sept 7 engineers began addressing a bug related to historical reporting of new vs returning visitor metrics. A fix went into production shortly thereafter. Historical data rebuilds then began to correct that data. We will update this status page again when 100% of the rebuild jobs complete spanning the affected period of June 27, 2021 - early September, 2021. Many of them have already completed. Thank you for your patience.
Posted Sep 21, 2021 - 21:45 UTC
Update
Engineers determined the root cause of the issue behind the 'new' vs 'returning' visitor accuracy problems in historical reports. Engineers are working toward a complete resolution in the historical record. We will report on this status page when the rebuild jobs complete spanning the affected period of June 27, 2021 - early September, 2021.
Posted Sep 08, 2021 - 22:01 UTC
Identified
Engineers are addressing a bug related to historical reporting of new vs returning visitor metrics. More details: Our support team identified a bug in the dashboard's historical reports, where ‘new’ vs ‘returning’ visitor metric segments are not reported correctly for dashboard reports run over periods older than 5 days old. The total number of visitors reported shouldn’t be affected. Data prior to July 27, 2021 is unaffected and no data is lost. Engineers are working on a fix, and will report on this status page when historical data record has been corrected.
Posted Sep 07, 2021 - 18:32 UTC
This incident affected: Analytics Dashboard.